top of page

The Appography Group

Public·15 members
Robert Anderson
Robert Anderson

Cannot Load Libmysql.dll Error Code 193 \/\/FREE\\\\



I'm trying to deploy an oracle application to another machine that uses the dbxora.dll file from dbexpress. I have included the file with the program but when i run the program and try to execute a query, it returns with an error that it could not load the dbxora.dll.




cannot load libmysql.dll error code 193



So you installed the 64 bit version and tried the 32bit lib's which of course fail to load. So far so normal. Now, while my libmariadb.dll has the same size as yours, your 64bit libmysql.dll has a different size than mine:


Console log:Installing mysql2 (0.3.13)Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. C:/Apps/Ruby/Ruby193/bin/ruby.exe extconf.rbchecking for rb_thread_blocking_region()... yeschecking for rb_wait_for_single_fd()... yeschecking for rb_hash_dup()... yeschecking for rb_intern3()... yes*** extconf.rb failed ***Could not create Makefile due to some reason, probably lack ofnecessary libraries and/or headers. Check the mkmf.log file for moredetails. You may need configuration options.Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=$opt-dir/include --with-opt-lib --without-opt-lib=$opt-dir/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Apps/Ruby/Ruby193/bin/ruby --with-mysql-dir --without-mysql-dir --with-mysql-include --without-mysql-include=$mysql-dir/include --with-mysql-lib --without-mysql-lib=$mysql-dir/libextconf.rb:37:in `': undefined method `[]' for nil:NilClass (NoMethodError)Gem files will remain installed in C:/Apps/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/mysql2-0.3.13 for inspection.Results logged to C:/Apps/Ruby/Ruby193/lib/ruby/gems/1.9.1/gems/mysql2-0.3.13/ext/mysql2/gem_make.outAn error occurred while installing mysql2 (0.3.13), and Bundler cannot continue.Make sure that `gem install mysql2 -v '0.3.13'` succeeds before bundling.


The error "extconf.rb:37:in `': undefined method `[]' for nil:NilClass (NoMethodError)" refers to this code:...if RUBY_PLATFORM = /mswinmingw/ inc, lib = dir_config('mysql') # Ruby versions not incorporating the mkmf fix at # -lang.org/projects/ruby-trunk/repository/revisions/39717 # do not properly search for lib directories, and must be corrected unless lib[-3, 3] == 'lib' # !!! line 37 !!! @libdir_basename = 'lib' inc, lib = dir_config('mysql') end exit 1 unless have_library("libmysql")elsif mc = (with_config('mysql-config') Dir[GLOB].first) then...


The funny thing is that MySQL 6.0 hasn't been invented yet. It turns out ( stackoverflow.com/questions/8740868/mysql2-gem-compiled-for-wrong-mysql-client-library ) what rake actually means is that it needs a version from MySQL C Connector. Long story short, what I've actually need to do is to go to dev.mysql.com/downloads/connector/c/6.0.html (exactly this version, not the latest one), download "Windows (x86, 32-bit), ZIP Archive" and extract libmysql.dll to Ruby bin directory.


'ITerm-1A.exe' (Win32): Loaded 'U:\Programs\WindowsApps\Microsoft.NET.CoreFramework.Debug.2.2_2.2.27031.1_arm__8wekyb3d8bbwe\System.Collections.Immutable.dll'. Exception thrown at 0x77206BEF (KernelBase.dll) in ITerm-1A.exe: WinRT originate error - 0x80070002 : 'System.IO.FileNotFoundException: The system cannot find the file specified.


Thanks Roland for the great article. I recently needed to do this but using Windows Vista x64 and Visual Studio 2008. The overall process was similar but there are a few differences to note:1) Visual Studio 2008 comes with the platform SDK included. Thus, I did not need to add the platform SDK paths noted above. (You will find the platform SDK includes/libs in C:\Program Files\Microsoft SDKs\Windows\v6.0A)2) I am running 64-bit mysql server and so I had to compile a 64-bit binary. Failing to do so would result in the "ERROR 1126 (HY000): Can't open shared library 'file.dll'" when attempting to create the function in MySQL.3) After compiling everything and resolving the file open problem, I still got the "ERROR 1127 Can't find symbol". I was sure I spelled everything correctly and had defined HAVE_DLOPEN when compiling. Turns out, my UDF code was not windows friendly. You must have __declspec(dllexport) before each extern'd item for it to be actually exported in the dll. You can verify your functions are exported by using the VisualStudio command prompt and typing: dumpbin /exports file.dllThe recommended way of marking up your UDF for Windows support is this:#if defined(_WIN32) defined(_WIN64)#define DLLEXP __declspec(dllexport)#else#define DLLEXP#endif/* Prototypes */extern "C" DLLEXP my_bool function_init( UDF_INIT* initid, UDF_ARGS* args, char* message ); DLLEXP ulonglong function( UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error ); // etc...Having all this taken care of, I was able to add the UDF to mysql on windows x64. I hope this helps someone else!


Hi Roland. I am attempting to install the lib_mysqludf_stat ( version 0.0.3) udf on Vista from the UDF repo. I used VC Studio express 2010 to compile it with the MySQL 5.1.33 server complete with the include and lib directories.I am receiving the ERROR 1127 (HY000): Can't find symbol 'lib_mysqludf_stat_info' in libraryerror.I verified that the code had the following:#ifdef HAVE_DLOPENSince those were the two instances that seemed to cause this error, are there other ones that I need to check?Thanks, Cliff.


HI,I followed the steps mentioned in the below link to install UDF on my Linux where i installed mySQL 5.1 _mysqludf_sys/index.phpSteps done:1. downloaded the tar.gz and tried running the install.sh but its not working and throwing errors.Can you suggest the correct way to get this installed. Basically my requirement is to invike a shell scriot from a mySQL trigger...Please suggest if anyother easy way is there.


Hallo Herr BoumanMein Name ist Khosro Tvakkoli und habe folgende Probleme. Mein Email-Adresse ist khosrotavakkoli@web.de.Beim Installation bekomme ich folgende Felher.Kannst du mir vielleicht dabei helfen?Herzlichen Dank=====================Mysql-version: mysql-server-5.1Config-file: /et c/mysql/my.cf=====================lib_mysqludf_preg-1.0.1# uname -aLinux milkyway 2.6.32-5-686 #1 SMP Wed May 18 07:08:50 UTC 2011 i686 GNU/Linux=====================lib_mysqludf_preg-1.0.1# ./configurechecking for a BSD-compatible install... /usr/bin/install -cchecking whether build environment is sane... yeschecking for a thread-safe mkdir -p... /bin/mkdir -pchecking for gawk... nochecking for mawk... mawkchecking whether make sets $(MAKE)... yeschecking build system type... i686-pc-linux-gnuchecking host system type... i686-pc-linux-gnuchecking for style of include used by make... GNUchecking for gcc... gccchecking for C compiler default output file name... a.outchecking whether the C compiler works... yeschecking whether we are cross compiling... nochecking for suffix of executables...checking for suffix of object files... ochecking whether we are using the GNU C compiler... yeschecking whether gcc accepts -g... yeschecking for gcc option to accept ISO C89... none neededchecking dependency style of gcc... gcc3checking for a sed that does not truncate output... /bin/sedchecking for grep that handles long lines and -e... /bin/grepchecking for egrep... /bin/grep -Echecking for fgrep... /bin/grep -Fchecking for ld used by gcc... /usr/bin/ldchecking if the linker (/usr/bin/ld) is GNU ld... yeschecking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -Bchecking the name lister (/usr/bin/nm -B) interface... BSD nmchecking whether ln -s works... yeschecking the maximum length of command line arguments... 1572864checking whether the shell understands some XSI constructs... yeschecking whether the shell understands "+="... yeschecking for /usr/bin/ld option to reload object files... -rchecking how to recognize dependent libraries... pass_allchecking for ar... archecking for strip... stripchecking for ranlib... ranlibchecking command to parse /usr/bin/nm -B output from gcc object... okchecking how to run the C preprocessor... gcc -Echecking for ANSI C header files... yeschecking for sys/types.h... yeschecking for sys/stat.h... yeschecking for stdlib.h... yeschecking for string.h... yeschecking for memory.h... yeschecking for strings.h... yeschecking for inttypes.h... yeschecking for stdint.h... yeschecking for unistd.h... yeschecking for dlfcn.h... yeschecking for objdir... .libschecking if gcc supports -fno-rtti -fno-exceptions... nochecking for gcc option to produce PIC... -fPIC -DPICchecking if gcc PIC flag -fPIC -DPIC works... yeschecking if gcc static flag -static works... yeschecking if gcc supports -c -o file.o... yeschecking if gcc supports -c -o file.o... (cached) yeschecking whether the gcc linker (/usr/bin/ld) supports shared libraries... yeschecking whether -lc should be explicitly linked in... nochecking dynamic linker characteristics... GNU/Linux ld.sochecking how to hardcode library paths into programs... immediatechecking whether stripping libraries is possible... yeschecking if libtool supports shared libraries... yeschecking whether to build shared libraries... yeschecking whether to build static libraries... yeschecking for gcc... (cached) gccchecking whether we are using the GNU C compiler... (cached) yeschecking whether gcc accepts -g... (cached) yeschecking for gcc option to accept ISO C89... (cached) none neededchecking dependency style of gcc... (cached) gcc3checking for mysqlbin... checking for mysql_config... nonoconfigure: error: "Can't find mysql library"lib_mysqludf_preg-1.0.1#=====================


About

This will be the space for members to discuss the secrets of...

Members

  •  SchüRm$_HIMself
    Early Member, Down from the jump. Since Day One. Much Love.Day One
    Subscribe to Any CategorySubscriber
  • Ezra Rivera
    Ezra Rivera
  • Yeremey Fomin
    Yeremey Fomin
  • Robert Anderson
    Robert Anderson
  • William Franco
    William Franco
bottom of page